2

I am new to this mining, I started yesterday with downloading the chains for geth and today it finished and so I got the newest version of ethminer. But when I start it this comes:

JSON-RPC problem. Probably couldn't connect. Retrying in 1... m 17:30:29|main Getting work package... X 17:30:30|main Failed to submit hashrate. X 17:30:30|main Dynamic exception type: class jsonrpc::JsonRpcException std::exception::what: Exception -32003 : Client connector error: libcurl error: 7 -> Could not connect to http://127.0.0.1:8545

I have searched in several Forums about this, but I don't know what to do? Please help thanks! Btw. I am using the latest version of windows 10 and use a gtx 1060 3gb. Andy

  • Hi there. It looks like your mining software isn't able to connect to Geth on port 8545. What command and flags did you use to start Geth? – Richard Horrocks Jun 27 '17 at 15:54
  • I just used geth -rpc in the command prompt and that just added chains and did his thing. – user12013 Jun 27 '17 at 15:57
  • Try restarting Geth using --rpc --rpcport 8545. – Richard Horrocks Jun 27 '17 at 16:02
  • Great - glad it worked! :-) – Richard Horrocks Jun 27 '17 at 16:09
0

As per the comment discussion, this error:

libcurl error: 7 -> Could not connect to http://127.0.0.1:8545

...is the important part.

To ensure Geth exposes this port (8545) as an RPC interface, it should be started with the --rpc --rpcport 8545 options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.