I've downloaded mix for OS X from here: https://github.com/ethereum/webthree-umbrella/releases

but every time I try to open it, it stops, and I get the error "mix quit unexpectedly"

I've tried downloading different versions, but the same thing happens every time.

How do I fix this?


1 Answer 1


I downloaded the binary from here and it works on my system (OSX El Capitan). Mix is under hard development as I understand so a thing might be working today, but broken tomorrow. Just have a bit of patience (I know it's frustrating ;) ).

If that doesn't work for you, maybe you could also try homebrew. Haven't tried it myself but it should be as easy as:

brew update
brew upgrade
brew tap ethereum/ethereum
brew install cpp-ethereum
brew linkapps cpp-ethereum

Or ...

brew install cpp-ethereum --with-gui

If none of these things work consider installing Sublime or Atom. I find they are more pleasant to work with but don't provide the debugging options that Mix has.

  • Please try not to post link-only answers. Could you consider adding more details for instance on how to install Mist through homebrew?
    – q9f
    Commented Mar 23, 2016 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.