2

I had ran ethereum for some time for developing. I had upgrade to the latest Mist 0.8.10, Wallet 0.8.10 and geth 1.6.5 on Windows 10. after this, everything seems to break, everytime i start my mist it will shows "node connection error".

After i deleted everything from User\Appdata - mist, wallet, geth and reinstall mist again (without separately installing geth). it is working ok until i switch from main to testnet. the same problem occured.

anyone have experience to resolved this issue and switch from main to testnet seamlessly?

i have no problem running geth from command line before launching mist or wallet. It will sync all the blockchain when mist starts.

enter image description here

  • For me inside C:\Users\<Your username>\AppData\Roaming\Ethereum Wallet\binaries\Geth\unpacked there was a geth.exe. I runned it as a administrator then everything worked fine. – Pramesh Bajracharya Nov 19 '17 at 12:48
1

Run mist.exe as administrator.

0

Are you sure that geth is running? The "node" that mist can't connect to is (I assume) a geth node on your computer. If geth isn't running, then mist can't "connect to node" and you would get an error.

  • it is before i manually launched geth. if i ran geth in command line, this problem will go away. If i run geth in command line, i cannot switch between main and testnet from gui – NHK Jun 26 '17 at 11:42
  • Well you must have geth running or mist will not run. I think the error about the "node" is telling you that you have to have your node (ie - geth) running in order to connect. As far as switching between main and testnets, I don't know how to do that in Mist but that is a separate issue from the node error. – stone.212 Jun 27 '17 at 5:13
0

I had deleted the mist browser again and used the zipped version instead of installer version. The problem goes away..

0

I was also getting the "Couldn't connect to node? See the logs for more:" error. When I ran Geth, it was stuck on "Starting P2P networking" and could not connect.

What worked for me was installing Geth, copying the Geth shortcut, and adding --nat=none.

"C:\Program Files\Geth\geth.exe" --fast --nat=none

Afterwards, open the Geth shortcut and make sure that it connects and stays running before opening Mist.

Download Geth here: https://geth.ethereum.org/downloads/

0

My sollution was to use "Ethereum wallet" (zip version) instead of "Mist".

(No one sollution described above worked for me)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.