1

Currently I am unable to start mining using Claymores software. I followed CryptoBadgers guide completely:

http://www.cryptobadger.com/2017/04/build-ethereum-mining-rig-linux/

I keep getting this error when I try to initiate my miner by typing this command

./miner.sh

ETH: 1 pool is specified
Main Ethereum pool is us1.ethermine.org:4444

Catalyst 15.12 is REQUIRED for best performance and compatibility
For Polaris cards, use latest drivers
At least 16 GB of Virtual Memory is required for multi-GPU systems
Make sure you defined GPU_MAX_ALLOC_PERCENT 100
Be careful with overclocking, use default clocks for first tests
Press "s" for current statistics, "0".."9" to turn on/off cards, "r" to reload pools, "e" or "d" to select current pool
OpenCL initializing...

AMD Cards available: 1
GPU #0: Pitcairn, 3072 MB available, 8 compute units
POOL/SOLO version
Cannot build OpenCL program for GPU 0
Segmentation fault (core dumped)

I am currently using a Radeon R9 370 for a GPU and I installed the following driver:

http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx

This is also on Xubuntu 16.04.2.

Miner settings:

#!/bin/sh
export GPU_FORCE_64BIT_PTR=0
export GPU_MAX_HEAP_SIZE=100
export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export GPU_SINGLE_ALLOC_PERCENT=100

./ethdcrminer64 -epool us1.ethermine.org:4444 -ewal 4d562bdab44696995251dd7bf743bbaf09b8b16e.Miner01 -epsw x -mode 1 -tt 68 -allpools 1

Can anyone explain what I have to do to fix the following error?

Cannot build OpenCL program for GPU 0
Segmentation fault (core dumped)
  • Have you try to remove export GPU_FORCE_64BIT_PTR=0 – Steffel Jun 23 '17 at 13:39
  • @SteffelFenix hey Steffel yes, I tried doing that as well. It appears that linux doesn't have drivers to support my card. However, I ended up using Windows 10. Drivers and everything works fine... but low MH/s – Alexander Sinno Jun 26 '17 at 20:58
1

I had same issue, it worked when I deleted these ones :

export GPU_FORCE_64BIT_PTR=0
export GPU_MAX_HEAP_SIZE=100
export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export GPU_SINGLE_ALLOC_PERCENT=100

also I did not use start.sh, I used console with these:

./ethdcrminer64 -epool eth-eu1.nanopool.org:9999 -ewal 0x<wallet>.<rig>/<mail> -epsw x -mode 1 -ftime 10
1
  1. Make sure you have the AMDPRO driver installed from http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx

  2. Test your driver version by executing

    dpkg -l amdgpu-pro
    
  3. Many cards do not support the GPU_FORCE_64BIT_PTR=0 setting under Ubuntu.

Remove this setting from your environment or your miner.sh file:

    #export GPU_FORCE_64BIT_PTR=0
    export GPU_MAX_HEAP_SIZE=100
    export GPU_USE_SYNC_OBJECTS=1
    export GPU_MAX_ALLOC_PERCENT=100
    export GPU_SINGLE_ALLOC_PERCENT=100
    ./ethdcrminer64 <your parameters here>

Hope this helps

0

I had a same problem with my claymore software. I downloaded and installed the microsoft c++ runtime for claymore (mining version) and it was worked. http://how-to-mine.com/softwares/runtimes/Microsoft_C++_Runtime.zip This solution worked for me.try it. i hope you can solve your problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.