I want to run on a test network using metamask but Solidity IDE auto connects to my real parity wallet. How can I switch that?

  • Disable the parity chrome extension and enable metamask. Wondering why you prefer one over the other? – Afr Jun 22 '17 at 9:01
  • @5chdn still wondering? ;) – Albert Renshaw Nov 7 '17 at 18:32

In Remix/Browser-Solidity:

  1. In the right-hand settings panel select "Contract".
  2. Under "Environment" select "Injected Web3".

MetaMask and the Parity browser extension don't work well together, since they both attempt to inject the web3 API, so whichever one loads first gets over-written.

You'll have to:

  1. Right-click one of the extension icons in your browser toolbar.
  2. Select "Manage Extensions"
  3. Uncheck the one you don't want to use so it is not "active".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.