2

When I enter eth console I get this back img and am not given a prompt back to give any commands. Also when I go to enter the password, it does not give me a prompt, but typing in my password and hitting enter still seems to work. I have already looked at this question here, and have tried the answers given. I still cannot enter commands. I am running windows 10, and eth 1.2.1

EDIT: It does eventually start doing the blockchain synchronization, but I am nonetheless unable to enter commands. If I run a test network eth --private 234 --genesis-json C:\ether\CustomGenesis.json --db-path C:\ether\ctestchain console It still just hangs at JSONRPC

CustomGenesis.json:

{
    "nonce": "0x0000000000000042",
    "timestamp": "0x0",
    "parentHash": "0x0000000000000000000000000000000000000000000000000000000000000000",
    "extraData": "0x0",
    "gasLimit": "0x8000000",
    "difficulty": "0xf00",
    "mixhash": "0x0000000000000000000000000000000000000000000000000000000000000000",
    "coinbase": "0x3333333333333333333333333333333333333333",
    "alloc": {
    }
}
  • Possible duplicate of Can't enter any commands after starting eth – Waqar Lim Mar 5 '16 at 18:12
  • I had included a link to that question and stated that the answers given in that question did not resolve the issue. – Anandamide Mar 5 '16 at 18:17
  • since you are still running eth version 0.9.41 you didn't really read the answers over there. please upgrade to at least 1.2.1 to be prepared for the homestead hardfork. – Waqar Lim Mar 5 '16 at 18:25
  • That still doesn't answer the question, while I am now updating it, I should still until the hardfork be able to use this client. I am not the only person obviously who has had this issue so it stands to reason that there is a solution with the current client. – Anandamide Mar 5 '16 at 18:30
  • Ok, and now that ive updated It still does not work, I will change details in the post to reflect so, but the issue is definitely still present – Anandamide Mar 5 '16 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.