I have some servers, and I want to try one of my servers to mine ethereum, I do not use GPU here because I only have a regular server, I see geth documentation,


I run the command

1) ./geth --datadir data --password pass account new

2) ./geth --datadir data --etherbase 0 --mine

I think I just need to install the geth only in ubuntu, and I create a new user ethereum, and start mining, is that correct?

I do not know my mistake,I leave a few hours, geth still active, but geth die after 1 day,

I also get a warning,

WARN [06-19|03:36:36] System clock seems off by -23m41.944063959s, which can prevent network connectivity 
WARN [06-19|03:36:36] Please enable network time synchronisation in system settings.

According to the documentation, i can mine eth just with geth, what is my mistake?


I don't think the warning is related to geth crashing, but you do need to make sure your servers' clocks are set to the right time or else you won't be able to sync the blockchain. You can use something like ntp to keep your clock synchronized.

  • Okay, I will sync my server time. I do mining with 2 steps, create user, and do mining with geth, is that correct? Or need --fast - cache or something like that? I also see some issues in github ethereum Https://github.com/ethereum/mist/issues/947 There, there is a statement that time-synchronization is not necessary Sorry, if I do not understand about github issues, Jun 19 '17 at 22:29
  • I believe you're referring to the comment where the Windows 10 user is told to disable and reenable time synchronization. This forces the clock to synchronize immediately (instead of once every several... days?). No additional options are required for geth to work, but I'm still not sure what is causing your crashes.
    – lungj
    Jun 20 '17 at 3:02

geth crash on my server because my server has certain security, if CPU and RAM usage exceed 90% for 1-2 hours server will reboot, my server is in technician configuration to avoid DDOS attack, sorry about that

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.