0

I have setup a private blockchain in AWS micro instance using go-ethereum. In that when I start the mining process it was taking nearly 2-3 hours to mine a new block.Whereas on my local machine it was taking 30 mins initially to start after that it took 1 sec to mine a new block. In Genesis block, I had assign difficulty as 0x400.

{
    "config": {
        "chainId": 15,
        "homesteadBlock": 0,
        "eip155Block": 0,
        "eip158Block": 0
    },
    "nonce": "0x0000000000000042",
    "difficulty": "0x400",
    "gasLimit": "2100000",
    "alloc": {
        "0xc490758cadb047809fa59df82a2057e6407784ab": { "balance": "100000000000000000000000000" },
        "0xa4f6f95b6cb36025dd09c9f5fe068e401951e963": { "balance": "10000000000000000000" }
    }
}
2
  • I think you are having problems with the dag generation, don't you? Commented Feb 15, 2018 at 9:43
  • For private blockchain you can use PoA then the block time can reduce to seconds.
    – Tony Dang
    Commented Sep 6, 2018 at 9:30

2 Answers 2

0

Please use t2 medium instances of AWS. Preferrably 2 instances. connect the 2 nodes by addPeer, Start mining in one instance. connect nethereum on the other and transactions would take 4-5 seconds.

1
  • 2
    Can you explain why?
    – Greg
    Commented Feb 15, 2018 at 10:04
0

The following points to consider

  1. Adjust/lower the mining difficulty in the genesis file.

  2. Increase the hardware capacity AWS micro instance to large.

  3. Ensure you should have enough peers by adding more nodes using admin.addPeer('enode_Address').

  4. Adjust/lower gaslimit this will not directly increase the mining speed may increase the transaction speed for a block.

  5. Ensure you have chosen PoA consensu/clique consensus algorithm depends upon your requirements.

  6. Make sure peer nodes are properly sync.

  7. Adjust geth --cahche 1024 according to the system hardware requirements refer this link :https://geth.ethereum.org/docs/fundamentals/command-line-options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.