3

THE PROBLEM I AM TRYING TO RESOLVE: ethminer.exe stops working when I execute the bat file below. It initially worked fine for about two weeks and then it stopped working. I have no idea why.

I have an RX480 GPU running on a 64 bit Windows 10 system. And I use Nanopool

I get a message from Windows that ethminer.exe has stopped working and then shuts it down.

Here is (below) what is displayed on the CMD Line. The bat file stops at the CMD output of "miner 10:51:32.581|main Grabbing DAG for #3868abc5" You can see that the last three characters are corrupt (but the string shows the beginning of the actual DAG file name "#3868abc5")

C:\Users\User\Desktop\Eth\Miner>setx GPU_FORCE_64BIT_PTR 0

SUCCESS: Specified value was saved.

C:\Users\User\Desktop\Eth\Miner>setx GPU_MAX_HEAP_SIZE 100

SUCCESS: Specified value was saved.

C:\Users\User\Desktop\Eth\Miner>setx GPU_USE_SYNC_OBJECTS 1

SUCCESS: Specified value was saved.

C:\Users\User\Desktop\Eth\Miner>setx GPU_MAX_ALLOC_PERCENT 100

SUCCESS: Specified value was saved.

C:\Users\User\Desktop\Eth\Miner>setx GPU_SINGLE_ALLOC_PERCENT 100

SUCCESS: Specified value was saved.

C:\Users\User\Desktop\Eth\Miner>cd /

C:>cd "Program files"

C:\Program Files>cd "cpp-ethereum"

C:\Program Files\cpp-ethereum>ethminer.exe -G --cl-extragpu-mem 0 --no-precompute -M --opencl-device 1 --opencl-platform 1 -F http://eth-asia1.nanopool.org:8888//worker1/piaras.me@gmail.com Found suitable OpenCL device [Ellesmere] with 8589934592 bytes of GPU memory miner 10:51:31.832|main Getting work package... miner 10:51:32.581|main Grabbing DAG for #3868abc5

WHAT I HAVE TRIED SO FAR:

  • I used "--cl-extragpu-mem 0 --no-precompute" (gained from the Internet help searches)

  • I updated the RX480 drivers and reloaded cpp ethereum (via the wizzard)

  • I started with deleting the DAG files from Ethash - when I re-ran the above bat file it started to build a new DAG file. When it finished, Windows simply shut it down again (with same Windows message). Now when I subsequently delete the DAG file(s), before I execute the bat file, it no longer attempts to build a DAG file (it just hangs as above)

None of these strategies made any difference

SOME QUESTIONS THAT COULD PERHAPS HELP ME SOLVE THIS PROBLEM:

  • Where would I look for a possible error code? Somewhere in Mist or the Wallet itself perhaps? I use Mist as my wallet.

  • Does Nanopool collect error data?

  • Does cpp ethereum itself have an error register (in this instance Windows does not offer an error code that I am aware of?).

Thank you to Nicolas Massart, Badr Bellaj, and 5chdn for offering feedback to my original question. I have included additional information to make the problem clearer. Please let me know if there is any other information that would help in assisting me.

Kind Regards

Piaras

  • Hi. Thanks for requesting an answer from me and other better qualified people thanks me. This site is managed by community, so you can't request answers from specific people. Also, if you posted this question and it was put on hold, there's no use to create it again. Simply modify your initial question and we will evaluate if it should be reopened. So I will vote for closing this question and I highly impel you to go back to the original post and edit it. Thanks. – Nicolas Massart Jun 26 '17 at 9:33
  • OK - I can't find the original post? Can you assist with this? Or maybe peruse the above content and refer me to a site that specifically deals with this kind of issue (I am close to abandoning the whole idea of eth mining). – Piaras Jun 27 '17 at 1:31
  • I'm sorry, I never tried to mine with windows, but I not sure the dag name corrupted chars are saying anything about your problem, this could simply be a display problem, windows shell is not known to be the best one, especialy for special characters... – Nicolas Massart Jun 27 '17 at 8:13
  • Thanks for getting back on this matter Nicolas - I have taken a second look at one of the Q&A's namely at : ethereum.stackexchange.com/questions/18615/… Although the hardware is different to mine the resulting software issue is very similar: miner 15:47:47|main Getting work package... miner 15:47:47|main Grabbing DAG for #129656acΓǪ You will notice that the last characters of the DAG file name are corrupted - perhaps this is worthy of attention (it does not appear to have been resolved) – Piaras Jun 27 '17 at 14:55
  • 1
    Following on from the same Q&A at ethereum.stackexchange.com/questions/18615/… "... The OS thought the Miner was a Virus and blocked it, something wrong with the compilation of the Library .dll (and copying one from elsewhere worked), to change your Mining Software" There is no indication from Norton 360 that ethminer.exe has been blocked (unless there is something I am missing?) - no error message regarding dll and I have reloaded the Mist software - any assistance from the 'been there and done that' would be much appreciated? – Piaras Jun 27 '17 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.