0

I removed chaindata db by doing "geth removedb" and am doing a fresh download of the blockchain. I allocated 2048 MB of RAM to my geth sync by submitting "geth --syncmode 'fast' --cache=2048 console". After running that for a few minutes, I opened my Mist briefly and then closed it (don't know why I did that, but I did) and after a few hours, my geth RAM allocation is now up to 4 GB...did my opening of Mist accidentally double the geth RAM allocation in downloading the blockchain?

My geth version is:

Geth Version: 1.6.1-stable Git Commit: 021c3c281629baf2eae967dc2f0a7532ddfdc1fb Architecture: amd64 Protocol Versions: [63 62] Network Id: 1 Go Version: go1.8.1 Operating System: linux GOPATH= GOROOT=/usr/lib/go-1.8

Also, my Mist wallet is the most up to date version as currently seen on github today.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

Some of the v1.6 (and even 1.7) releases have a known Out of Memory (OOM) issue, where memory leakage causes incremental usage of system memory until an error is thrown or your process starts using swap memory. I've personally found that setting your --cache option not more than one eighth of your system RAM is good practice. I usually set to 512 and not more 1024 (geth default is 128) on a system with 8GB memory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.