10

I am using Claymore's Dual Ethereum v9.5

Here is my config file:

setx GPU_FORCE_64BIT_PTR 0
setx GPU_MAX_HEAP_SIZE 100
setx GPU_USE_SYNC_OBJECTS 1
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_SINGLE_ALLOC_PERCENT 100
EthDcrMiner64.exe -epool eu2.ethermine.org:4444 -ewal 0x9C57aE119dd13EE9Cd444Cf96091f1e84446.rig-epsw x

I keep getting this error: "CUDA error: cannot allocate big buffer for DAG"

enter image description here

From what I've read this happens when graphics memory is too low. I use a Nvidia 750Ti with 2GB.

How can I fix this ?

  • 1
    Hi there. The message in the error says "Check readme.txt for possible solutions." Have you checked that file? Do any of the suggestions help? I'm suspecting the size of the most recent DAG has breached 2GB, in which case you might be out of luck. Others may have more helpful suggestions though :-) – Richard Horrocks Jun 11 '17 at 9:06
  • Hi Richard, I think you are right. I guess I will have to buy a new graphics card. – user6800816 Jun 11 '17 at 9:10
  • Furthermore, GTX 750 Ti's (Maxwell chipsets) suffer an exponential hashrate degradation the larger the DAG grows. So even the 4Gb models are effectively worthless for mining. – o0ragman0o Jun 11 '17 at 23:36
  • 1
    I have geforce 1060 6gb cards and facing same problem in same claymore version. Tried other versions too – RAJA ICHPLANI Jun 15 '17 at 18:23
  • Yep, same graphics card, same error. Got to get that new graphics card basically. – Vidar Jun 18 '17 at 11:26
8

to form an answer:

@richard's comment in the previous is right, the DAG file's size is the source of your problem, your GPU needs to load it before start mining. Since mid-2016 it is no more possible to mine using a 2GB graphic card while the DAG file has exceeded 2GB. we will reach 3GB in April 2018.

5

Check you PAGE file size - it should be more than 16000 MBs. Keep minimum 16000 MBs and maximum 20000 MBs. A majority of the miners rely on virtual mem to keep the process quick and it requires a good amount of size allocation.

I have 4x gtx 1060 6GB and was have this error until i changed the page size/virtual memory

0

When your video cards meet or exceed current DAG requirements, your pagefile is within spec and everything else has been functional... Launch 2 instances of the miner at the same time. This forces a DAG recreation on the second instance. Just kill the miner that is still choking. There will be a few errors thrown about

server: bind failed with error: 10048 (port for remote management is busy, use different -mport value), next attempt in 20sec...

Everything seems to work from there on-ward. I speculate it has something to do with DAG cache and epoch increases, but /shrug

Claymore v9.5 with latest nVidia drivers... I can post logs if needed.

If this helps you Eth: 0x7e5c4Bb4343f0313cfddd56dD4A9c21F43DFDefD

0

Quite an obvious thing: this error might be also caused by the lack of free space on the hard drive.

What needs checking:

  1. Amount of free space on disk
  2. Video card memory size
  3. Page file memory size
0

I had this problem and expanding the virtual memory and trying to spam two instances at the same time didn't work.

My fix, which fixed this immediately, was to add "-lidag 0" to the command line. This creates the DAG buffer at the lowest intensity which apparently help with stability.

From the Readme!!!.txt:

-lidag low intensity mode for DAG generation, it can help with OC or weak PSU. Supported values are 0, 1, 2, 3, more value means lower intensity. Example: "-lidag 1". You can also specify values for every card, for example "-lidag 1,0,3". Default value is "0" (no low intensity for DAG generation).

I hope this helps somone as it took me a long time to figure out myself.

If this doesn't work, try -eres 0

protected by Community Sep 4 '17 at 17:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.