2

I run local swarm node, so I can access it from localhost:8500. RPC request works fine locally. But when I try to send requests to swarm rpc from another server, it is not accessible. I see port 8500 is only open locally.

Seems very strange. Are there any options to open it for the network?

  • how do you try to access it? – Badr Bellaj Jun 7 '17 at 9:31
  • I have no rep to comment, so reply here: I try to send request by RPC – gelbplaneten Jun 7 '17 at 9:39
0

This should have been addressed by providing the httpaddr flag:

https://github.com/ethereum/go-ethereum/pull/14475

Per default swarm runs on localhost only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.