3

I am new to mining ethereum and have been trying to set it up for the last few hours. I have created a coinbase wallet and have followed the advice given in this question. The accepted answer has me run the command

ethminer -G -F http://yolo.ethclassic.faith:9999/0x<YOUR_WALLET_ADDRESS> --farm-recheck 200

However I keep getting the error

miner 16:05:28.730|ethminer Getting work package... ✘ 16:05:38.732|ethminer Failed to submit hashrate. ✘ 16:05:38.732|ethminer Dynamic exception type: jsonrpc::JsonRpcException std::exception::what: Exception -32003 : Client connector error: libcurl error: 28 -> Operation timed out So I thought that perhaps the server is offline. So I tried connecting to a different pool, e.g. ethpool.org. Unfortunately I find it very hard to find out what I should do to start mining. On the website there is a list of stratum servers, the europe one being eu1.ethpool.org:3333. So I tried the command

ethminer -G -F eu1.ethpool.org:3333/0x<YOUR_WALLET_ADDRESS> --farm-recheck 200

and get the error

miner 16:12:09.399|ethminer Getting work package... ✘ 16:12:12.696|ethminer Failed to submit hashrate. ✘ 16:12:12.696|ethminer Dynamic exception type: jsonrpc::JsonRpcException std::exception::what: Exception -32603 : INTERNAL_ERROR: : {"id":999,"jsonrpc": "2.0","result": false,"error": "Invalid JSON request"}

I tried different variations of this command but always get the same error.

I also tried mining without a pool. For this I run

geth --rcp

and in another terminal

ethminer -G

This seems to work but I don't know how to tell ethminer to mine for my coinbase wallet. Where should I put my coinbase address in the above two commands?

  • ethminer -G -F eu1.ethpool.org:3333/0x<my wallet name> --farm-recheck 200 as well as ethminer -G -S eu1.ethpool.org:3333/0x<my wallet name> --farm-recheck 200 but i get the error message Invalid Argument: 200 We have double checked and our wallet name is correct, however we still cannot access it to see our digging. Any other thoughts? – Lucas Bonetti Oct 29 '17 at 10:12
3

Coinbase explicitly mentions you should not be mining to their wallet addresses. You CAN mine to any JAXX address though which makes an easy to use solution.

Once you have a wallet setup on Jaxx, you can see your public address in the default view. There is even a copy button to make it easy to grab. Note, you can create and use > 1 address with each wallet as well.

  • 1
    I set up a wallet with "geth account new". If I now type ethmine -G do I mine into that wallet? How do I check the contents of that wallet? Sorry for these very basic questions. – MichalisN Jun 6 '17 at 19:05
2

I'm not sure that Coinbase allows for direct transactions like that, maybe they do, but you really should host your own wallet. There are plenty of great mobile wallets as well that you can set up in under five minutes, and more importantly hosting your own wallet gives you greater control of your funds. Not to mention, the IRS in the United States is expected to release a statement on requesting records on Coinbase users for tax purposes tomorrow. If they start taxing crypto, other western democracies will surely follow suit. Why give any government any more control over you?

Back to your main issue. It does seem to be a problem with reaching the pool. In addition to what you have already tried, I'd do the basics like trying to disable your firewall and pinging to server and port directly from terminal to make sure it's reachable. Otherwise, your command looks correct:
ethminer -G -F eu1.ethpool.org:3333/0x<YOUR_WALLET_ADDRESS> --farm-recheck 200

Also check to make sure you aren't making a dumb mistake anywhere, like including the carrots (<, >) in the URL and making sure that the address you are trying to use is in fact valid Ethereum addresss (try searching it on https://blockchain.info/)

EDIT:

You might also have to specify a worker name after the address. The worker name can be whatever you want, so the command would be something like:
ethminer -G -F eu1.ethpool.org:3333/0x<YOUR_WALLET_ADDRESS>.<NAME> --farm-recheck 200

Also, as @mcstar has confirmed, Coinbase discourages mining to addresses on their exchange. It's best to use your own wallet client.

  • It could be that the server I was trying was just down... not sure yet. – MichalisN Jun 6 '17 at 19:03
  • Try pinging it. Sorry if you have terminal experience and this is obvious to you, but in a terminal window run the command ping eu1.ethpool.org or ping eu1.ethpool.org:3333. If you consistently get a response (i.e. no packets are dropped, the server is up) – user9402 Jun 6 '17 at 19:06
  • 1
    Of course I should've done that. the server is online. – MichalisN Jun 6 '17 at 19:08
1

Don't know if you've been successful with this or not, but try replacing -F with -S. According to "ethminer --help", -S is required for a Stratum server. Use -F only if you are mining on a getwork farm.

ethminer -G -S eu1.ethpool.org:3333/0x --farm-recheck 200

(assuming eu1.ethpool.org:3333 is a Stratum server)

Let us know how you're doing!

1

I'm using ethermine.org and this command worked for me on Ubuntu:

ethminer -G -S us1.ethermine.org:4444 -O 0x8aec081e391d275dc0fb8e4697fc252359d353f8.worker1 --farm-recheck 200

0

I usually just enter these commands in terminal

geth console

miner.start(8)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.