2

I was syncing the blockchain using something like geth --fast --cache=2000 -jitvm. It reached about block #3819000, and then it did something odd. It stopped saying "Imported x reciepts" or "Imported x headers", and began saying "Imported x block(s)," and the count reset to 0. What is this? Why does it do this? Importing blocks takes longer than reciepts/headers, and those took me 23 hours! Can someone explain this?

6
  • It may have reached the latest block at the time, when does that happen geth will switch automatically to download blocks.
    – Ismael
    Jun 4, 2017 at 23:47
  • Why. Why does it start over and do that? Jun 5, 2017 at 0:10
  • If the two times geth have been started with the same command line it should not have been reset to 0. If you need to restart geth before the synch was complete, then you should reset the database with geth removedb, or else it will start synhronizing in normal mode (ethereum.stackexchange.com/a/13156). In the last version the correct parameter is --syncmode=fast.
    – Ismael
    Jun 5, 2017 at 0:19
  • I have the latest version. Sync mode is not a valid argument it says. If I have to stop it, it won't do fast sync. And if I don't stop it, and it reaches the most recent block, it stops getting headers and receipts and fetches block from #0 instead. Jun 5, 2017 at 0:22
  • You should download from geth.ethereum.org/downloads. I've testes with v1.6.5 geth --syncmode=fast --cache=1024 and it works properly.
    – Ismael
    Jun 5, 2017 at 1:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.