I configured a private testnet according this guide:


Now I would like to connect my testnet to MyEtherWallet which is running on my local computer. If I try to connect with the testnet I get the following error message:

Could not connect to the node. Please refresh the page, or see the help page for more troubleshooting suggestions.

What do I have to do in order to connect to my tesnet?


1 Answer 1


Your JSON-RPC API endpoint must be set up to allow access not only from localhost but from the wider public network too. If your rpcaddr flag is set to localhost, then the external MyEtherWallet site cannot connect to it. Setting rpcaddr to will open it up to all public access, but then make sure you know what you're doing if you also are storing Ether in that node's wallet; it's now publicly-accessible, making it easier to lose your funds there.

Related question: How can I expose Geth's RPC server to external connections?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.