6

I have been struggling with this issue for about 3 weeks now and could find nothing on forums and discussions online.

I have a GPU Rig with the following specifications:

  • 6x PowerColor Red Devil RX580 Golden Sample GPU
  • 6x Molex Powered Riser Boards with Molex to Sata Adapter Cables
  • Biostar TB250-BTC Motherboard
  • 4GB RAM
  • Intel Celeron G3900 CPU
  • Corsair AX1200i PSU
  • Windows 10 64 bit

The issue I have is that Windows recognizes the GPUs, directly plugged into the MB or on the Risers, however, when I only use the risers, I get a black screen if more than 4 cards are installed.

I use Minergate to mine Ethereum, once the DAG file is created, I either get a hash rate of 0 H/s, or I get a blue screes saying DRIVER_IRQL_NOT_LESS_OR_EQUAL.

I have reinstalled Windows from another source to make sure it is not a Windows error. I re-downloaded the latest AMD Drivers and an older version and it still gives me the same issue

I have Minergate running perfectly on my home PC with an NVidia GTX970 (just mining to test and not for profit) with no such issues.

Could it perhaps be incompatibility issues? I do not really have the funds to buy more parts to swap and test, but because I have 6 cards and 6 risers I can test them all separately, which I have.

I also installed Ubuntu 16.04, which also picked up the GPU, but when I installed the latest drivers, it would not allow me to pass the login page, which I could do before the drivers were installed. I managed to get past the login page once after the installation, but I was stuck on a hash rate of 0 H/s

If anyone has experienced a similar problem, please assist where possible.


UPDATE

I previously flashed the bios with the same version it was on, still gave the same issues, and then updated to the latest version, still the same. There is however no posts of people using this bios version because it is so new.

I did notice one thing though, our Internet was down yesterday, so the Rig could not mine, so I did not get the Windows Blue Screen error, but as soon as the internet is back, the blue screen returns.

Did another BIOS update, blue screen is still there, so I believe the problem either lies with the motherboard or ALL the GPU's, as they all do the same. I think chances are bigger that the issue is with the MB because I have had issues with a few boards I have purchased.

We bought another MB yesterday, I do not get the Blue Screes anymore, but occasionally freezes a few times after each other. Still not getting any hashes

  • Any update on this? I'm having the same issue with this board. Using 1 RX 580 and 5 RX 460s – user9973 Jun 8 '17 at 6:22
  • No updates as of yet. We will be doing more test today. If you are also getting the blue screen, have you perhaps tried using a PCI network card? I still need to buy/find one so have not been able to test that – Rickus Harmse Jun 8 '17 at 6:30
  • We bought another MB yesterday, I do not get the Blue Screes anymore, but occasionally freezes a few times after each other. Still not getting any hashes – Rickus Harmse Jun 9 '17 at 6:27
  • The same problem has occurred to me, too. HIS Rx580 x1 – Are2sy K Jun 11 '17 at 19:07
  • I added an answer, hope this will help you all, after losing all hope we tried EthOS and this works amazing – Rickus Harmse Jun 12 '17 at 7:24
5

This sounds like a riser issue. Try rotating risers or trying different riser cables. It may fix the issue. Because this is a cross-OS persistent issue, it screams hardware or bios. I'd try updating the bios too, or even reflashing to the current or previous version (be careful, this can introduce incompatibility to some CPUs!)

Hope you find the root cause of your problems!

  • Thanx for the answer, I did however flash the bios to the same version it was on and to a newer version prior to this post. There is currently one GPU connected directly to the MB and the risers not connected, and still giving the same issue. I did read that the error I got was most likely due to Faulty Network Drivers, which I have updated multiple times with the same result, but when there is no internet, there is no blue screes, as soon as the internet returns, I get the blue screes, so I think it might be the MB, will test with PCI Network card and post back – Rickus Harmse May 31 '17 at 6:20
0

After looking for an issue for way too long, we decided to try EthOS, this is working perfectly sofar, and with this we were able to determine that one of our GPUs is faulty.

I am still unsure why we were getting this issues with Windows and Linux, but for us EthOS saved the day. I hope this will be able to help you all.

EthOS is very easy to get running and 5 of our cards were running immediately!

protected by Community Jun 14 '17 at 9:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.