1

I am trying to reacquire access to a coinbase account that I used as the repository for ethereum I was mining almost 2 years ago. I have the json file corresponding to the correct address. I have verified that the balance I expected the account to have is still there using the Etherscan.io website. My questions are:

1) Do I need to wait for geth to download the entire blockchain before I can expect the correct balance to show up in response to an eth.getBalance command in the console? Obviously I haven't completed the downloading of the complete blockchain yet so I am trying to determine why the getBalance command is giving me a zero now.

2) I have a .ethereum folder from a now defunct operating system that I used some to ago. The chaindata folder contains over 18,000 items. The current operating system has geth installed but the chaindata folder contains only 6700 items. Can I expedite the blockchain synchronization by moving the blockchain data from the old install to the current one .... I'm referring to the contents of the chaindata folder specifically. If so are there files outside of the chaindata folder that also need to be moved with it, like a folder with index files ... or something like that?

3)When I started mining ethereum I made sure to take careful notes and to make backups of anything that might prove to be important later so I backed up the.json file and also a file with a name that starts with "UTC--2015-09-07". I am running Kubuntu 16.04. I added the 3 ppa's for ethereum, updated the packages database and then installed the ethereum and cpp-ethereum packages. To import my old account into this new installation I moved the json file and the UTC.. file into the ~/.ethereum/keystore/ folder. When I run eth.accounts at the console I now see two accounts one of which is the correct eth address I am trying to recover. When I run

geth --etherbase --unlock 0 console 2>> geth.log

I am prompted for a password which I expected because my notes include the password that I specified when I set up the account. When I type in the password though I see the error message "Failed to unlock account 0 (could not decrypt key with given passphrase"

I have spent hours looking for a clue regarding what I am doing wrong. Any assistance or advice you can offer me would be most appreciated.

Thank you, markoff

  • You might have better chances of attracting the right problem-solvers and getting these questions answered if you make your core issue clearer in the header. For instance: "Tech challenges related to coinbase account recovery." You might also do better if you break down your challenges and questions into separate posts, to increase the chances that someone can answer one of your questions. Good luck :) – Tesa May 30 '17 at 7:50
  • Good advice, I'm sure though I'm not sure why breaking my post into multiple posts would increase the chances that someone will answer one of them. I don't require people to answer all of my questions. Certainly they can answer one question and not respond to the others ... there is nothing preventing that. :-) – Markoff May 30 '17 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.