3

I was installing Truffle in Ubuntu 16.10 using sudo, but I got the following error message:

npm WARN wrtc@0.0.63 license should be a valid SPDX license expression

npm ERR! Linux 4.4.0-59-generic

npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"

npm ERR! node v6.10.3

npm ERR! npm v3.10.10

npm ERR! code ELIFECYCLE

npm ERR! wrtc@0.0.63 install: node-pre-gyp install --fallback-to-build

npm ERR! Exit status 1

npm ERR! Failed at the wrtc@0.0.63 install script 'node-pre-gyp install --fallback-to-build'. npm ERR! Make sure you have the latest version of node.js and npm installed. > npm ERR! If you do, this is most likely a problem with the wrtc package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: node-pre-gyp install --fallback-to-build

npm ERR! You can get information on how to open an issue for this project with: npm bugs wrtc npm

Or if that isn't available, you can get their info via: npm owner ls wrtc

  • It seems this error is a bug in Ubuntu 16.10. Is a solution available? – ProgramSpree May 30 '17 at 11:53
  • Do you have all prerequisites of wrtc package installed? npmjs.com/package/wrtc#prerequisites – Igor Barinov May 30 '17 at 13:17
  • Yes, I have tried the apt-get prerequisite installation. The same error persists. – ProgramSpree May 30 '17 at 13:38
2

Had the same issue on 16.10 Use --binary flag with truffle install command And avoid -g, the modules are harder to track if instaĺled globally

  • 1
    Tried sudo npm install --binary truffle. Same error still. – ProgramSpree Jun 4 '17 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.