8

I am running geth 1.6.1 and trying to sync to ropsten testnet. When I start geth, it seems to be downloading blocks and state entries. When I run web3.eth.syncing, I get currentBlock: 986300 and is increasing every time I run. However, when I do web3.eth.getBlock('latest').number, it returns 0. All my account balances (web3.eth.getBalance) are also returning 0.

Command I use to start geth:

geth --testnet --rpc --rpcapi db,eth,net,web3,personal --cache=1024 --rpcport 8545 --rpcaddr 127.0.0.1 --rpccorsdomain "*" --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@52.169.14.227:30303,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@13.84.180.240:30303"

  • Could you solve this? I am having the same issue. – Stefan Falk Jun 5 '17 at 19:01
  • No, upgraded geth to 1.6.5 and still same issue – maheshmurthy Jun 6 '17 at 3:19
  • It works for me now. It seems that syncing just takes really long - several hours. I am now getting the latest block. – Stefan Falk Jun 6 '17 at 7:17
  • Good to know, thanks. Although, I did fast sync and usually it only takes me few minutes. I will try again. – maheshmurthy Jun 6 '17 at 11:56
  • Well I am a complete noob here so I might be mistaken. However, I think geth is enabled on default so I am sure I had it enabled too. Yet I had to wait quite a while. I observed that eth.hashrate was getting larger over time and that eth.syncing was also changing - so if you see that behavior you really might just have to wait that long. Once it's done it shows something Starting mining task or something. Or write miner.start() into the console after running geth console and see what it says .. maybe it returns that it is syncing. – Stefan Falk Jun 6 '17 at 14:11
0

It sounds like your geth isn't synced correctly or finished syncing yet.

Please type this into your geth console:

eth.getBlock("latest").number

You should get something equal or higher than 4,372,173 If you don't that means you need to let your geth fully sync properly.

It takes a long time to sync properly. It can be frustratingly long to sync sometimes. I have had the same issue and I let it sync for literally days before it worked properly.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.