It seems that whenever I run Parity and I bring up :8545 in a web browser (locally or on the public net), it redirects to :8180 OR simply gives me an error. In this case, I get the Parity UI styling saying:

404 Not Found
Your homepage is not available when Trusted Signer is disabled.

You can still access dapps by writing a correct address, though. Re-enable Signer to get your homepage back.

What I am expecting is the "normal" weird error I would get if I ran geth and looked at port 8545 in a browser. Text gobbledegook that I could re-create and post if you need the details.

But what I really want to be able to do is execute commands via the RPC interface across the public internet. Is there another, better way that I should be going about this?

1 Answer 1


There is no reason to access an HTTP RPC port via a browser and thus Parity forwards you to the Wallet UI.

If you want to access RPC via HTTP, you can use curl or similar.

curl --data '{"method":"web3_clientVersion","params":[],"id":1,"jsonrpc":"2.0"}' -H "Content-Type: application/json" -X POST localhost:8545

If you want to use the RPC API via your JavaScript console, you can open the Parity Wallet, navigate to the Applications tab and open the Parity Console dapp.


> web3.version.node
< "Parity//v1.7.0-unstable-18c3e90db-20170523/x86_64-linux-gnu/rustc1.17.0"

I hope this answers your question.

  • 1
    It does, and I knew not to access the RPC via browser. But since I was trained to expect one behavior from geth, Parity's behavior was confusing me. Might I suggest a redirect message that say "you are trying to access the RPC port via browser. Redirecting to the Parity UI console DAPP." Or something? That way I don't worry that I've got my reverse proxies misdirected.
    – stone.212
    Commented May 24, 2017 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.