2

I'm running the eth client (0.9.41) on Windows 10 using the following command:

eth --frontier -b -i  

as stated here.

The program hangs and I'm not able to enter any commands. The last produced text starts with: "Node ID: enode://e449..., 'setTimeout not available in this environment'".

What am I doing wrong?

I found a similar issue here.

The same situation is on Windows 7.

  • you need -console – user697 Feb 28 '16 at 22:14
  • 2
    @user697 OK, eth --console is starting, but it hangs with the same message: setTimeout not available in this environment – romanoza Feb 28 '16 at 22:33
  • 1
    added an answer, but just reading the version you use, maybe try 1st to upgrade ? – euri10 Feb 29 '16 at 16:49
  • 2
  • 1
    Yes you have to upgrade to 1.2.0+ as soon as possible regarding the upcoming homestead fork. – Afr Mar 1 '16 at 10:56
4

You need to open a console, like that:

eth --frontier console

The -b -i flags don't exist anymore. The docs really need to be updated.

Edit: And please update your client to version 1.2.0 or later as soon as possible.

  • Unfortunately, the symptoms are the same. I ended up using Geth, it's more reliable for me at the moment. – romanoza Mar 2 '16 at 10:46
1

Check if your router has upnp enabled. If upnp is not enabled, you can use the --upnp off option and port forward the 30303 port to your machine by yourself.

  • Yes, the port is OK. I'm using Geth at the moment and everything is working fine (more or less). – romanoza Mar 2 '16 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.