1

I am using ethereum-ruby to deploy smart contracts. I am using JSON RPC calls to my geth and its working pretty well. But when i use compile_solidity I get:

"error"=>{"code"=>-32603, "message"=>"eth_compileSolidity method not available: solc (solidity compiler) not found"}}

and if I do get_compilers it returns "".

I installed solc it with npm. What am I missing?

5

I solved this by installing solc with apt-get like

sudo apt-get install solc

Then I typed which solc and it told me it was installed at /usr/bin/solc. So I fired up geth console and used the command

admin.setSolc('/usr/bin/solc')

to point to the path. Then it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.