2

I'm trying to integrate safe-global/auth-kit and upon initialization of SafeAuthPack I'm getting CORS issues on localhost. Is there any workaround for this?

enter image description here

enter image description here

1
  • Hey Chufta, thanks for your question! We were able to replicate the bug and confirm we had the same issue. We are currently looking into what could be causing the problem. Please hang tight! Commented Feb 29 at 13:27

1 Answer 1

0

It seems that the txServiceUrl: "https://safe-transaction-polygon.safe.global" is incorrect, URL should be https://safe-transaction-polygon.safe.global/api.

Since the SDK will automatically map the correct URL to the chain you are using, you can actually remove this parameter entirely and simply do new SafeAuthPack().

Hope it helps! Best, Louis

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.