0

enter image description hereenter image description here INFO [02-20|20:41:18.478] WebSocket enabled url=ws://127.0.0.1:8551 INFO [02-20|20:41:18.478] HTTP server started endpoint=127.0.0.1:8551 auth=true prefix= cors=localhost vhosts=localhost

> admin.nodeInfo
{
  enode: "enode://69fe165f1360dbc709bb39f4f4553c0b9c2d83d05a50b8c4cf6acc48d28276de5801e7a556ba6bd03e44f1bc48888356d293141c8e1babde439febe7a840c1d1@127.0.0.1:30306",
  enr: "enr:-KO4QBP2z5qlXS6rf1hvY2t9bpZGSigiOkK96Tvf3j0gkjT7PTbl5vAPbeKd3uDNTXFN4Sfq4xB1c_OknALnPqjwotuGAY3Gzc3fg2V0aMfGhPxDpb6AgmlkgnY0gmlwhH8AAAGJc2VjcDI1NmsxoQNp_hZfE2Dbxwm7OfT0VTwLnC2D0FpQuMTPasxI0oJ23oRzbmFwwIN0Y3CCdmKDdWRwgnZi",
  id: "028dac93450f939bc3d75f14ac3a801561e68c5e01361b993a970e4f6a37d208",
  ip: "127.0.0.1",
  listenAddr: "[::]:30306",
  name: "Geth/v1.13.12-stable-02eb36af/windows-amd64/go1.21.6",
  ports: {
    discovery: 30306,
    listener: 30306
  },
  protocols: {
    eth: {
      config: {
        arrowGlacierBlock: 0,
        berlinBlock: 0,
        byzantiumBlock: 0,
        chainId: 7007,
        clique: {...},
        constantinopleBlock: 0,
        eip150Block: 0,
        eip155Block: 0,
        eip158Block: 0,
        grayGlacierBlock: 0,
        homesteadBlock: 0,
        istanbulBlock: 0,
        londonBlock: 0,
        muirGlacierBlock: 0,
        petersburgBlock: 0
      },
      difficulty: 4519,
      genesis: "0xe76aa0f8f05f787fdebd69e572a83980cb508abb7c86974676cab0239fd5725c",
      head: "0x0bcef0f3ea2d3272303f05f921695c76832dcc8d451b0f36129af7a12e13b2a1",
      network: 7007
    },
    snap: {}
  }
}

1 Answer 1

1

According to the values you provide, the RPC URL is as follows;

http://127.0.0.1:8551

In the output you provided, it is stated here;

INFO [02-20|20:41:18.478] WebSocket enabled url=ws://127.0.0.1:8551 INFO [02-20|20:41:18.478] HTTP server started endpoint=127.0.0.1:8551 auth=true prefix= cors=localhost vhosts=localhost

4
  • I used 127.0.0.1:8551 and chain id 7007 but it did not work. I also used 127.0.0.1:8545 as well, since it seemed to be the general suggestion. Feb 22 at 17:55
  • According to the endpoint information you provided, the rpc url is "127.0.0.1:8551" Try adding a slash "/" at the end Feb 22 at 19:47
  • I tried it as well. It doesn't work. Feb 22 at 20:59
  • I got this issue solve with adding --syncmode full --http --http.addr 0.0.0.0 --http.api admin,eth,miner,net,txpool,personal,web3 --allow-insecure-unlock --http.corsdomain “” --http.vhosts “” --http.port 8545 Base on the article medium.com/coinmonks/… Mar 3 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.