0

I'm not really a React/Next dev and I'll appreciate some help.

I need to use a multisig on my blockchain, with pretty basic functionality:

  • Managing signers
  • Signing TXs by signers

I've searched through the multiple Safe's pages and found two approaches that possibly suit me the most, since I don't need all the plugins/auth kit/...

  1. safe-wallet-web
  2. @safe-global/cra-template-safe-app

safe-wallet-web approach

When I'm trying to install safe-wallet-web I have dependency issue.

❯ git clone https://github.com/safe-global/safe-wallet-web.git
Cloning into 'safe-wallet-web'...
remote: Enumerating objects: 38186, done.
remote: Counting objects: 100% (6264/6264), done.
remote: Compressing objects: 100% (3201/3201), done.
remote: Total 38186 (delta 3804), reused 4821 (delta 2897), pack-reused 31922
Receiving objects: 100% (38186/38186), 15.22 MiB | 11.78 MiB/s, done.
Resolving deltas: 100% (24620/24620), done.
❯ cd safe-wallet-web
❯ yarn
yarn install v1.22.19
[1/5] 🔍  Validating package.json...
[2/5] 🔍  Resolving packages...
[3/5] 🚚  Fetching packages...
[##################################################---------------------------------------------------------] 1000/2141 [#######################################################----------------------------------------------------] 1108/2141^R
[##########################################################-------------------------------------------------] 1153/2141m[##########################################################-------------------------------------------------] 1160/2141.[##########################################################-------------------------------------------------] 1167/2141
info There appears to be trouble with your network connection. Retrying...
info There appears to be trouble with your network connection. Retrying...
info There appears to be trouble with your network connection. Retrying...
info There appears to be trouble with your network connection. Retrying...
error An unexpected error occurred: "https://registry.yarnpkg.com/@mui/icons-material/-/icons-material-5.15.1.tgz: ESOCKETTIMEDOUT".
info If you think this is a bug, please open a bug report with the information provided in "/Users/tikonoff/Projects/fv/safe-wallet-web/yarn-error.log".
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

I've tried that few times, has the same issue. Needless to say, I have no connection issue on other repos. Any ideas how to fix it?

I've also tried NPM,

❯ npm i
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: [email protected]
npm ERR! Found: [email protected]
npm ERR! node_modules/cypress
npm ERR!   dev cypress@"^12.15.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer cypress@"^2.1.0 || ^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0 || ^7.0.0 || ^8.0.0 || ^9.0.0 || ^10.0.0 || ^11.0.0" from @testing-library/[email protected]
npm ERR! node_modules/@testing-library/cypress
npm ERR!   dev @testing-library/cypress@"^8.0.7" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

npm i --force is a complete disaster.


Create react app approach:

I've also tried to install UI by npx create-react-app safe-safe-app --template @safe-global/cra-template-safe-app, and also had some dependencies issues, e.g. @mui/material and others, which I fixed manually, and it worked, it tries to connect to Safe.

If this approach is preferable, then I need .env.example which is absent in the repo. :( Anyone has it?

Did I miss something? Which way to look? Thank you.

1 Answer 1

0

Yarn version should be upgraded.

3.6.0 or 4.x will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.