0

I'm working on adding our chain custom Chain so that we can use safe within our network. i went and asked for singleton factory address here:

Got this tx with the created contract.

Next I cloned this repo and followed the doc to set it up locally. All good until I am trying to create a safe and it says:

Error: Invalid CompatibilityFallbackHandler contract address

I was checking additions like these but they seem to have multiple addresses, I only got one from the initial request.

How can I make it work locally?

1 Answer 1

0

After having the singleton factory you need to deploy the safe contracts https://github.com/safe-global/safe-contracts and add the addresses https://github.com/safe-global/safe-deployments

3
  • Once the steps above are completed, you should wait until a new version of the Safe{Core} SDK is realeased with the safe-deployments dependency up to date (given the error I'm assuming you are using it). Otherwise, if you don't want to wait for the new release of the SDK, you can already use it once the contracts are deployed initializing it with the contractNetworks option: docs.safe.global/safe-core-aa-sdk/protocol-kit/reference#create
    – Germán
    Jan 16 at 16:39
  • When I am trying to deploy safe-deployments using npm run deploy-all $networkName I get: Safe factory not found for network $NetworkNo. You can request a new deployment at https://github.com/safe-global/safe-singleton-factory. For more information, see https://github.com/safe-global/safe-contracts#replay-protection-eip-155 Jan 18 at 15:18
  • NVM I managed to deploy hardcoding info variable in hardhat.config.ts Jan 18 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.