0

We are struggling to withdraw funds from our Safe on Optimism.

A couple months ago, we sent funds on Optimism to our Safe multisig address - which was only set up on Mainnet at the time. Realizing our mistake, and to recover the funds, we followed a step-by-step guide to create an optimism wallet on the same address (following Case 1 from the article since we had Safe version 1.3.0).

Article reference: https://help.safe.global/en/articles/40812-i-sent-assets-to-a-safe-address-on-the-wrong-network-any-chance-to-recover

We followed this loom step-by-step guide, and luckily the funds were there when it was set up (https://www.loom.com/share/ca34aabcd62747fb9fb89bd463b4c741).

However - the Safe on Mainnet was originally set up by two of my colleagues who later changed the co-signer settings to include me and another colleague. The new Optimism wallet we created defaulted back to the original settings, so we are not co-signers on this one. My colleague (who set up the original Safe) is unable to add us to it, and he’s also unable to confirm transactions to send any tokens out (screenshot below). Are we stuck or what do you suggest? Can we fix this to withdraw our funds and, even better, make this Optimism wallet work correctly?

enter image description here

We also tried Safe CLI which helped a bit: "I was able to add a confirmation using the command line (CLI interface). But still can't execute using the web interface." (screenshot below)

enter image description here

2
  • Hi! I think that more information will likely be necessary. You may want to consider dropping the address if you're comfortable doing so, and I'd recommend asking the current signer to run Tenderly simulations of adding additional signers and/or confirming the txs, and to paste here whatever errors would be encountered in execution. Jan 4 at 10:32
  • The address is 0x371cA2c8f1D02864C7306e5E5Ed5DC6edF2DD19c. Will look into Tenderly, thanks for the tip!
    – Cori
    Jan 4 at 16:54

3 Answers 3

0

Have you tried using the Safe CLI? For any issues related to Safe{Wallet}, feel free to ask support directly on help.safe.global, using the chat button in the bottom right corner of the page.

Hope it helps, Louis

2
  • Thanks Louis, yes we tried Safe CLI. "I was able to add a confirmation using the command line (CLI interface). But still can't execute using the web interface." I added a screenshot to the description above.
    – Cori
    Jan 4 at 16:47
  • I would suggest trying to either: 1. execute the transaction using CLI command execute-tx <safe-tx-hash>; or 2. transfer the remaining funds using the CLI with send_ether <address> <value-wei> [--safe-nonce <int>] and redeploy a new Safe on Optimism if you need to use the UI on this network. Jan 5 at 10:33
0

Yes I tried the CLI.

I was eventually able to execute the transaction that was pending (which was about adding Cori above and Guil as co-owners).

Now trying to move the funds to a new proper SAFE multisig on Optimism but it doesn't let me execute the transaction to move ETH (we also have some DAI to move).

It keeps on saying "Number of signatures 1 must reach the threshold 2".

Even though the interface shows that there has been 2 confirmations (that I was able to do with the CLI with the approve_hash command): enter image description here

I was even able to make two on chain approval with the sign-tx command:

Yet, whenever I try to run the command

execute-tx 0x342aeffda5c06ed57d73554e5c887e3762409dfcb2dbf4813c8767501f2ddd7a

I get Number of signatures 1 must reach the threshold 2

I also tried the command refresh and I also tried to quit and restart the CLI tool (and also tried to just wait hours in case it was just a cache issue).

I realized too late that there is a command to update the SAFE but it requires the nonce to be zero (it's now at 1).

Thank you for your support 🙏

0

Update on this: We were able to finally execute the transactions and recover the funds via den - https://app.onchainden.com/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.