0

I'm running 'forge install smartcontractkit/[email protected] --no-commit' to install Chainlink dependencies, but I encountered the following error:

'error: 2871 bytes of body are still expected MiB | 300.00 KiB/s fetch-pack: unexpected disconnect while reading sideband packet fatal: early EOF fatal: fetch-pack: invalid index-pack output fatal: clone of 'https://github.com/smartcontractkit/chainlink-brownie-contracts' into submodule path '/home/elyas6126/foundry-f23/fund-me/lib/chainlink-brownie-contracts' failed Error: git submodule exited with code 128'.

please help me

1

1 Answer 1

1

I had the same issue installing chainlink brownie smartcontract kit.The solution to it was I first cleared the Git cache

git rm -r --cached .
git add .
git commit -m "Clear Git Cache"

Then cd into the lib folder and clone the repository manually

git clone https://github.com/smartcontractkit/chainlink-brownie-contracts.git

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.