1

I'm on MacOS Seirra with Geth 1.6.0-stable. Last few days, tried doing fast sync using the following command.

$geth --syncmode fast --cache 4096

Every time, the sync process hangs with no active peers or ran for almost over night to find less than 10% of the blocks synced. BTW, I ran "syncmode fast" from scratch by clearing chaincode folder everytime.

I'm not on a lightning speed broadband line. even guess 14mbps should be better. My mac also can take more hammering with these specs. 2.93GHz i7 / 16GB RAM / 7500rpm

TIA

2

If your Mac has a regular hard drive (as opposed to SSD), it will definitely take a very long time. If you can't get a computer with an SSD, one thing I found that helped was this:

When you start geth use the --verbosity flag with a value of 5. This will spit out tons of text. It won't speed up your sync, but it will help you to understand that the node is not hung (because the text will continue to scroll by).

What happened to me is that I was repeatedly starting and stopping geth because it looked like it was hung, but every time I killed it, it would have to start over on the same block that was taking so long. And, even if it got past that one block, the next block would make it look like it was hung.

With the verbosity flag on, you will see that geth is not hung, so it's easier to allow it to continue operating until it finishes.

I know this seems like an odd suggestion, but it worked for me, and eventually I did get it to sync on a non-SSD computer. It took a very long time.

But I would strongly recommend getting a computer with an SSD.

2

As you stated, if no peers are discovered, there is nothing to download.

I suppose you are connected to the mainnet. It should discover peers automatically, but if it doesn't, you can add peers manually with admin.addPeer(), and check your connections with net.

Edit: To find a bootnode, you can check the list of peers here.

  • Yep, its mainnet. Tried adding peers from epool.io still the same. The sync process is dead slow. – eth.dev May 5 '17 at 10:00
  • Is it downloading a few blocks or none? During fast sync, it downloads blocks in batches of 1024, 2048 etc., maybe that's why it's slow. Can you please provide a console output in the question? – jeff May 5 '17 at 10:06
  • node.log in this link - pastebin.com/2X65LYi7 – eth.dev May 5 '17 at 10:11
  • It is downloading. Not sure about the speed though. 100 blocks/second seems slow. Also it doesn't say anything about fast sync. Can you try --syncmode=fast, with the equal sign? – jeff May 5 '17 at 10:41
  • unfortunately it's still the same with equal sign. I read somewhere with v1.6 defaults to fast mode. but couldn't find anything in logs about fast sync. – eth.dev May 5 '17 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.