0

I am using node to test solidity with a ReactJS front end. After IPFS required I used a SSL I had to add some changes to my nginx conf and now port 3000 is not being found.

I installed the SSL and nginx -t is all ok. Here is my congif file:

server {
    listen 80 default_server;
listen 8080;
listen [::]:80 default_server ipv6only=on;

root /usr/share/nginx/html/ipfs/src;
index App.js index.html index.htm;
listen   443 ssl;
server_name jenbil.com;
ssl    on;
ssl_certificate    /home/keys/jenbil.com.chained.crt;
ssl_certificate_key    /home/keys/jenbil.key;

When I try to access https://jenbil.com:3000 I get a not found error but http://jenbil.com works and also https://jenbil.com displays the ReactJS but no actual action is performed.

I am using npm start to run the development server.

Here is netstat -nltp:

root@ubuntu-512mb-nyc3-01:/etc/nginx/sites-enabled# netstat -nltp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1287/sshd       
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      24017/nginx     
tcp        0      0 104.236.58.158:8545     0.0.0.0:*               LISTEN      8702/geth       
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      24017/nginx     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      24017/nginx     
tcp        0      1 104.236.58.158:47508    93.108.217.34:*         SYN_SENT    8702/geth       
tcp        0      1 104.236.58.158:35970    66.41.106.197:*         SYN_SENT    8702/geth       
tcp        0      1 104.236.58.158:52430    124.176.170.179:*       SYN_SENT    8702/geth       
tcp        0      1 104.236.58.158:38030    86.155.52.143:*         SYN_SENT    8702/geth       
tcp6       0      0 :::22                   :::*                    LISTEN      1287/sshd       
tcp6       0      0 :::3000                 :::*                    LISTEN      23874/node      
tcp6       0      0 :::30303                :::*                    LISTEN      8702/geth       
tcp6       0      0 :::80                   :::*                    LISTEN      24017/nginx     
root@ubuntu-512mb-nyc3-01:/etc/nginx/sites-enabled# 

How can I get the 3000 port to be listened to or how can I not use that anyway in testing?

1 Answer 1

1
https=true npm start 

solves the immediate problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.