8

I'm testing a contract on testnet using Mist.

When I deploy it, it says "No data is deployed on the contract address!".

And then it doesn't appear on the contracts section.

What does it mean?

  • Can you be more specific on how you're deploying the contract? Does browser-solidity give any errors if you paste the contract code there? – Joël Feb 25 '16 at 0:01
  • You may not be using enough gas. Can you try setting the gas higher and redoing the transaction? – Tjaden Hess Feb 25 '16 at 1:38
  • I'm having this issue too. i'm using the Testnet Ropsten. I've increased the maximum gas provided to 7000000, which is the block gas limit for Ropsten, but still no data deployed. Any suggestions? Much appreciated! Thanks, Billie – Billie Oct 8 '17 at 17:55
  • this can also happen if you send ether to a contract that isn't payable – user3338098 Feb 9 '18 at 22:44
4

This happens if the transaction with your contract was mined, but them the wallet couldn't find data on this address using web3.eth.getCode(address). This happens if you don't provide enough gas for storing the contract. E.g. it was executed but not stored. This is an encase and shouldn't happen normally.

  • Same happened to me too. It's surprising. I provided 1eth for deploying ethereum-based Token, still no data is deployed on contract. I think that 4,739,336 gas is more than sufficient to deploy a simple token. – Prashant Prabhakar Singh Apr 21 '17 at 9:23
  • OMG Thank you I clicked on the blue link and made both values the same. Cost me .24 Ether to create my custom token. Now I have to find out what my custom tokens watch address is. So I can share with others! – Wingless May 3 '17 at 13:46
4

It can mean 'not enough gas'.

When you submit a contract using Mist/Ethereum Wallet you should always check that the 'Estimated fee consumption' is greater or equal to the 'Provide maximum fee' field. If it is not, then the gas in the 'Provide maximum fee' field can be increased simply by clicking on the blue link and then amending the value.

  • 1
    This helped me solve mine! But it's actually that your Estimated Fee Consumption should be less than the Provide Maximum Fee field. You have written "greater than". Thanks though, Jim! – rizzes Apr 25 '17 at 22:01
  • @rizzes my Estimated fee consumption IS less, but still I get the above error – dark_ruby Jun 24 '17 at 13:41
  • Ok turns out, estimated fee is not always accurate, and for contract to be succesfully published (especially on TestNet) your Maximum fee should be significantly greater than estimated – dark_ruby Jun 24 '17 at 13:45
0

This happened to me once and it was because the transaction contained a simple error: I sent Ether to the contract when I deployed it but the contract's constructor wasn't payable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.