3

In my contracts i'm using ether transfers which requires Solidity compiler 4.10. With newly updated truffle and solcjs version 4.10. I still get the following error using Truffle to compile the contracts.

Error: Source file requires different compiler version (current compiler is 0.4.8+commit.60cc1668.Emscripten.clang
4
+50

The current version of Truffle (v3.2.1) still depends on truffle-compile ~1.1.2. truffle-compile 1.1.2 depends on solc v0.4.8.

The next release of truffle-compile is v2.0.0, which bumps solc to v0.4.11.

In other words, you'll have to wait for truffle to finally release an update that depends on truffle-compile v2.0.0 or later--or fork truffle yourself and bump the truffle-compile dependency to v2.0.0 using a git url (since v2.0.0 isn't on npm yet)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.