0

I recently tried to connect a Safe Wallet through native WalletConnect App to my Dapp but I encounter the same issue that you can try on your own trying to use Uniswap on any testnet.

Basically what is happening is that I succeed in connecting the wallet and sending the transaction but:

  • If there's only one signer and the signer sign and send the transaction from the Safe in just one step, then the Dapp resolves and everything works.
  • If there are more than one signer or the sign is done first, and then the exeuction comes later, the Dapp will just hang waiting for wallet connect to resolve the tx result.

I just have a promise that doesn't resolve if sign and executions are done separatedly (which is always the case for more than one signer case scenario)

enter image description here

Any hint on what's going on ?

Notice that the tx from the safe correctly executes, just the WalletConnect callbacks doesn't trigger

1 Answer 1

0

Have you tried reaching out to https://help.safe.global/en? A dedicated support team will be able to answer your question relative to Safe{Wallet} there, whereas stack exchange will be more focused to developer questions.

Please let me know if you solved the problem in the meantime!

Thanks, Louis

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.