1

I have followed the guides from the documentation:

But when trying to initialize the API Kit I'm getting the error "TypeError: SafeApiKit is not a constructor".

  1. Initialize Signers, Providers and EthAdapter enter image description here

The ethAdapterOwner1 has data inside, is initialized correctly.

  1. Initialize the API Kit enter image description here

enter image description here

Any ideas? Thanks!

1 Answer 1

1

I had the same issue and fixed it by destructuring the default from SafeApiKit like this:

  const safeService = new SafeApiKit.default({
    txServiceUrl,
    ethAdapter: ethAdapterOwner1,
  });

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.