0

I am a noob when it comes to creating contracts. Every contract I try to deploy using the example code for new coin creation seems to have failed even though I paid for it, what am I doing wrong? Did I run out of "gas", if so how do I pay enough for it?

All contracts fail but still cost ether

0

Yes, you did run out of gas. There are two steps you need to complete to ensure that the contract has enough gas.

1) Ensure that you should have enough Ether in your wallet to be able to fund this transaction. If you are on a test net, you should be able to mine for Ether.

2) Also, check that the Maximum Gas provided is more than the estimated gas.

|improve this answer|||||
  • I tried deploying the contract with the fee slider set to maximum and it still failed. I paid 0.0928 ether fee, gas used 400,000 and gas price at 0.232 ether per million gas. What did I do wrong this time? – jotun Apr 17 '17 at 23:04
  • You will need to increase the maximum gas provided in the next screen. Unfortunately, the slider does not work too well. Have a look at this conversation which discusses how to increase the maximum fee provided. ethereum.stackexchange.com/questions/15249/… – Madduri Srikant Apr 18 '17 at 3:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.