1

I have tried to install a full Ethereum node (geth) on Ubuntu hundreds of times, but it keeps getting stuck on 'Looking for peers' and doesn't make any progress. Below are the steps I have taken so far:

  • Synchronized the date and time to match the Ethereum network timezone.
  • Disabled the firewall settings.
  • Tried several different ways to write the rpc, ws, and http ports.
  • And the others ...

Should I also install a consensus client to set up a full Ethereum node, or is it possible to do it just with geth? If anyone has experience with this, please help me.

1
  • For mainnet you need a consensus client.
    – Ismael
    Jun 4, 2023 at 4:41

1 Answer 1

2

you should sync with consensus client also to run the GETH execution client. For example, in my case I used lighthouse beacon node to sync with GETH. There might be several kinds of configurable settings to sync it and the two clients, execution and consensus clients are synced with the JWT. You can set it with /tmp/JWT

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.