I downloaded the safe contract latest release from https://github.com/safe-global/safe-contracts/releases/tag/v1.4.0 and i am trying to deploy the contract . I am trying to run npx hardhat --network mumbai deploy-contracts . I have added infura api key in .env , and other required api keys too but i am facing this error when i run the script

Compiled 47 Solidity files successfully failed to get chainId, falling back on net_version... Error HH110: Invalid JSON-RPC response received: {"jsonrpc":"2.0","error":{"code":-32002,"message":"rejected due to project ID settings"}}

Any idea how to resolve this?

2 Answers 2


it looks like there is a problem with your hardhat-cofig.js file , might be possible you are passing wrong chain id for the desired network to deploy. can you share the screenshot ? so i can figure out the issue


I think you do not have need to re-deploy #safe contract because it is already deployed on Mumbai, please check the following ref. for the contract addresses "https://github.com/safe-global/safe-deployments/tree/main/src/assets/v1.3.0", Mumbai chain Id is 80001 so you can use the contract address for this chain Id.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.