2

Hello !
I tried to run a transaction service locally using this guides:

{
 "chainId": "43113",
 "chainName": "Avalanche Fuji Testnet",
 "shortName": "avax",
 "description": "",
 "l2": true,
 "rpcUri": {
   "authentication": "NO_AUTHENTICATION",
   "value": "https://api.avax-test.network/ext/C/rpc"
 },
 "safeAppsRpcUri": {
   "authentication": "NO_AUTHENTICATION",
   "value": "https://api.avax-test.network/ext/C/rpc"
 },
 "publicRpcUri": {
   "authentication": "NO_AUTHENTICATION",
   "value": "https://api.avax-test.network/ext/C/rpc"
 },
 "blockExplorerUriTemplate": {
   "address": "https://testnet.snowtrace.io/address/{{address}}",
   "txHash": "https://testnet.snowtrace.io/tx/{{txHash}}",
   "api": "https://api-testnet.snowtrace.io/api?module={{module}}&action={{action}}&address={{address}}&apiKey={{apiKey}}"
 },
 "nativeCurrency": {
   "name": "Avalanche",
   "symbol": "AVAX",
   "decimals": 18,
   "logoUri": "/media/chains/43113/currency_logo.png"
 },
 "transactionService": "http://nginx:8000/txs",
 "vpcTransactionService": "http://nginx:8000/txs",
 "theme": {
   "textColor": "#ffffff",
   "backgroundColor": "#000000"
 },
 "gasPrice": [],
 "ensRegistryAddress": null,
 "recommendedMasterCopyVersion": "1.3.0",
 "disabledWallets": [],
 "features": []
}

Then I configured the webhooks by this address:
http://localhost:8000/txs/admin
with following values:

  • http://nginx:8000/cgw/v1/chains/43113/hooks/events
  • Basic some_random_token

But when i try to create safe, i saw errors in my console: enter image description here

with error code = 1337 enter image description here

enter image description here

Then i am back to main page and saw more errors in console: enter image description here

And when i try to select my wallet, i saw these errors: enter image description here enter image description here

In the last case, we see that chainid === 43114 instead chainid === 43113 somehow.
But i have only one chain.
What is going on?)))

2 Answers 2

0

We are not the Safe community, but I can provide some guidance.

It appears that your node configuration might be incorrect. Please use the official Avalanche website's settings for the Fuji Testnet:

Network Name: Avalanche Fuji C-Chain
RPC URL: https://api.avax-test.network/ext/bc/C/rpc
ChainID: 43113
Symbol: AVAX
Explorer: https://testnet.snowtrace.io/

Also, double-check the "l2": true value in your configuration, make these changes and see if the errors are resolved.

2
0

Hi there!

Looks like I solved this problem myself!

The problem was in:

  • Invalid setting of shortName parameter in chain settings. You need to use the values from the Eip-3779 page;
  • You need to add addresses of smart contracts of master copies and proxy factories on the configuration page. Addresses can be found here.

Also, I recorded a detailed video on setting up the service for Avalanche Fuji C-Chain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.