2

I am doing a BSC full node sync using the following command:

/mnt/raid/bscdata/geth --syncmode full  --config /mnt/raid/bscdata/config.toml --datadir /mnt/raid/bscdata/node --cache 32000 --rpc.allow-unprotected-txs --txlookuplimit 0

The sync process stopped importing new block headers at ~26.000.000 block and started a new process called "State sync in progress". From my understanding, a full sync will import the blocks first and then process those blocks after, from the internet I found that this process starts near the end of import process so in my case it started at 26m block. So this is ok.

The problem though is that it shows eta=191h43m49.052s which is huge, and I found that people manage to process it just a few hours.

Server hardware:

CPU:
Architecture:            x86_64
  CPU op-mode(s):        32-bit, 64-bit
  Address sizes:         46 bits physical, 48 bits virtual
  Byte Order:            Little Endian
CPU(s):                  32
  On-line CPU(s) list:   0-31
Vendor ID:               GenuineIntel
  Model name:            Intel(R) Xeon(R) CPU E5-2665 0 @ 2.40GHz
    CPU family:          6
    Model:               45
    Thread(s) per core:  2
    Core(s) per socket:  8
    Socket(s):           2
    Stepping:            7
    CPU max MHz:         3100.0000
    CPU min MHz:         1200.0000
    BogoMIPS:            4788.11
RAM: 64GB
STORAGE: 2 x 2T nvme software raid ~3.6T

LOG

t=2023-04-10T10:03:59+0000 lvl=info msg="State sync in progress"                 synced=0.07% state="403.58 MiB" accounts=1,165,[email protected] slots=1,578,[email protected] [email protected] eta=191h43m49.052s

Also, my cpu is at 3% chilling

How can I speed up the process? should I run geth without --syncmode full?

UPDATE, will see how it runs increasing cache to --cache 48000, and adding --gcmode full

After 1 day it managed to do some progress

t=2023-04-12T08:50:22+0000 lvl=info msg="State sync in progress"                 synced=74.82% state="408.35 GiB"  accounts=164,259,[email protected] slots=1,841,074,[email protected] codes=1,611,[email protected] eta=14h52m37.265s

But it stopped here for 12h, and now it's just importing new blocks. cpu is at 0%

2 Answers 2

1

There is some stuff you can try, the easier one would be to use your node with --syncmode fast option instead of --syncmode full it will allow you to download only the recent state of the chain, you can also check that you have a sufficient number of peers --maxpeers 100, and also check your network connection.

Increase the cache might help but in any case the ETA you see may not be entirely accurate, as it can fluctuate during the syncing process.

2
  • 1
    invalid value "fast" for flag -syncmode: unknown sync mode "fast", want "full", "snap" or "light" will try increasing max peers. it was 50 Apr 10, 2023 at 12:28
  • you could try with -light or -snap
    – Saxtheowl
    Apr 10, 2023 at 12:40
1

The issue was that I was connected to bad peers. I solved it by updating static peers and restarting geth service.

peers can be found here https://api.binance.org/v1/discovery/peers

also updated geth to the latest version

https://github.com/bnb-chain/bsc/releases/download/v1.1.22/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.