1

The Errors that i am getting when i am trying to compile the contract

The issue I am having is when I am trying to compile my contract, I am getting multiple errors for ERC721. As imported ERC721 is importing more contracts, as seen from the errors, the issue is that it is not found. I have installed openzeppelin globally and internally through npm, but the issue remains... I ran out of ideas to solve this issue and test my contract... I am adding the picture to have a broad idea of what I am dealing with. I would greatly appreciate any help.

1 Answer 1

1

Try changing your imports to:

import "@openzeppelin/contracts/token/ERC721/ERC721.sol";
import "@openzeppelin/contracts/utils/Counters.sol";
import "@openzeppelin/contracts/access/Ownable.sol";
1
  • Just tried it, still same issue all same errors come up when trying to compile... i also double checked what version of Openzeppelin contracts i have installed with npm and it shows the latest, v4.8.0
    – Hasbik645
    Apr 8, 2023 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.