1

enter image description here

I'm having error like this, even if I have sufficient eth (0.1-0.2 eth).

1
  • Are you using the same account in your config file which has the said balance? Commented Mar 24, 2023 at 12:54

1 Answer 1

0

There might be some fixes for this issue, check this out:insufficient funds for intrinsic transaction cost

Even if you are not able to resolve your error try doing this:

Use Sepolia instead of Goerli. Because from the past few weeks it has become expensive and the functions which required very less eth to run now requires many eth and it is also comparatively hard to get a large number of Goerli from faucets.

Also don't forget to change url/api key.

2
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review Commented Mar 24, 2023 at 12:49
  • Hey I'm the author of this post and I answered it as well. Because I faced this problem I tried to find a solution but there was none. So when I finally got the solution, I thought other people might be facing the same problem because geth has now value and people are using it more and more so this problem occured. So just wanted to help.
    – amit
    Commented Mar 24, 2023 at 15:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.