1

Currently i m working in remix and metamask. Before 1 month the metamask account connected to the remix ide but now it is not connecting. I tried updating the extension yet it is not working. I also changed my browser, previously i was working in chrome now i changed to edge, then to it is not working. I also tried creating new account instead of importing the old one, then also it is not connecting. enter image description here is there any other ways to make it work ?

network configuration enter image description here enter image description here

6
  • can you share the network configuration ? You will find it inside networks in metamask . Mar 14, 2023 at 6:35
  • i have added in question section @GauravPant Mar 14, 2023 at 7:23
  • everything seems to work fine . maybe the issue is with remix Mar 14, 2023 at 8:10
  • I too think so @GauravPant , But i m continuing a project i left a month ago and i need to connect to calculate the transaction cost. That's what i asked. Thank you for answering. Mar 14, 2023 at 8:35
  • if you know hardhat , see this ethereum.stackexchange.com/a/106535/111398 , maybe of some help Mar 14, 2023 at 10:54

2 Answers 2

0

Replying here instead of comment (level too low). It seems that it is a remix issue, since they updated recently.

Here are possible solutions:

  1. Connect to remix with other wallets (you will have to disable metamask in your plugins first)
  2. Hard refresh remix (you may want to save your code locally before doing this) press Ctrl+Shift+R or Ctrl+F5
  3. Use another browser to connect to remix

My fix for this situation was to finally learn how to use hardhat and foundry until a new stable remix version comes out. It gets also better to simulate tx cost with these tools.

5
  • I have already tried option 2 and 3, Its not working. I will check alternates for metamask or try using hardhat and foundry. Thank you for the valuable suggestions. @0xheartcode Mar 15, 2023 at 4:28
  • 1
    I just cleared Cache from my system and it worked. I can now connect metamask account and remix from chrome. yet, will learn other solutions too. Thank you. Mar 15, 2023 at 4:45
  • Glad I could help. So option 2 did not work but clearing the cache manually did ? Mar 15, 2023 at 7:17
  • 1
    Ya, like manually i went to browser settings cleared catch and cookies then freshly opened everything and it worked. also i removed the metamask extension and again added the extension back. Mar 15, 2023 at 8:27
  • CTRL F5 didn't help me. Just lauch a Docker image to operate my own Remix ... Guys... can you TEST your work before push it to all of us?
    – Magno C
    Jan 31 at 2:26
0

Clear Cache files in your system and now try connecting metamask from remix. Save your work before clearing catch. It worked. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.