0

i setup react native project with expo.

@metamask/sdk doesnt work on expo project

I already build with cli and success.

coinbase/sdk wants to use expo, i changed cli to expo.

now it doesnt work with metamask sdk.

reference: https://c0f4f41c-2f55-4863-921b-sdk-docs.github.io/guide/metamask-sdk-js/metamask-sdk-react-native.html

2 Answers 2

0

I have the same issue currently. The metamask sdk is based on react-native cli, but coinbase is based on expo. Maybe you should use the deep link in react native cli.

0

Check out this tutorial, it works with expo if you use eas: https://youtu.be/p7c92qrMBT4?si=CZn0v-XfAxgENob5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.