I can't sell alt-tokens back into ETH. This is an issue with multiple tokens, not just one and they all have very high liquidity ($Kabosu and $OHMI).

I immediately get the error 'gas estimation failed' when I try to initiate a trade to sell them into ETH. Even when setting the slippage to stupidly high levels like 10-20%, still the same problem. But if I initiate a transction to buy more of these alts with ETH, the uniswap trade proceeds normally with no issues at all.

I would really love some help with this as I have thousands in assets I'm unable to sell which is extremely frustrating and worrying. Thank you!

Things I've done to try and fix the problem:

Made a new metamask/eth wallet in a new browser (Opera instead of Firefox). Sent some alt-tokens + ETH over to try and sell them there. Still the same error.

Reset my PC.

Waited 5-20 mins between attempting trades.

Tried using 1inch swap instead of Uniswap. No luck.

Final notes:

I was getting some weird 'signature request' request to my Metamask which I've not seen before this week. I'm used to an approval transaction being sent over Uniswap costing around $1 but this is something else, asking to be signed in Metamask, that never seems to resolve properly and might be causing this whole issue. Even after signing I still can't sell the Alt.

I also completed a small ETH to USDT test transaction over uniswap with no issues, so my wallet isn't the problem.

I've been using uniswap for years with the ocassional issue, but nothing as bad as this one. Any help is greatly appreciated.

  • Same issue with Metamask and Ledger on Uniswap. Problem started today with both Ethereum and Arbitrum network. I was able to swap yesterday with multiple pairs. I'm continually asked to approve the same token then asked to sign message for Permit2. After approval, I'm given error message stating "Gas estimation failed. Wait a few minutes and try again." I also tried dextools but same issue. I created a ticket with Uniswap. Will keep everyone posted.
    – user115212
    Jan 21, 2023 at 8:52
  • Same issue when buying/selling/swapping any eth coins on uniswap. "Gas estimation failed. Wait a few minutes and try again."
    – user115214
    Jan 21, 2023 at 9:05
  • Uniswap is broken. I was able to use Sushiswap though.
    – gr33nTHumB
    Jan 21, 2023 at 23:09

1 Answer 1


I ended up using dextools and was able to swap no problem

Not the answer you're looking for? Browse other questions tagged or ask your own question.