2

I have a simple question but I cannot find the problem. I want to expose the RPC port of my node in my local network (so that I can access it from another computer).

I run the node with : geth --http --http.corsdomain=* --http.api eth,net,admin,web3,debug --datadir /opt/ethereum/execution --maxpeers 16 --authrpc.jwtsecret /opt/ethereum/consensus/prysm/jwt.hex

but

lsof -i -P -n | grep 8545

still outputs

geth TCP 127.0.0.1:8545 (LISTEN)

and not something like

[::]:8545

as I want it to be.

Do you know why the corsdomain parameter does not change anything ? Thank you in advance

1

2 Answers 2

0

That's a command I ended up to boot a node for my aims:

geth --allow-insecure-unlock --http --http.addr "0.0.0.0" --port $NODE1_PORT_UDP_TCP --http.corsdomain '*' --authrpc.port $NODE1_PORT_RPC --http.port $NODE1_PORT --http.api admin,personal,eth,net,web3  --datadir ./node1/data --miner.gasprice 0 --verbosity 3 &

Please note --allow-insecure-unlock is open node for some security attacks. As well as --http.corsdomain does too. They are here only for development stage - deployment and run in the production would require extra efforts to cover this security risks.

0

I was not looking at the right thing. I wanted

[::]:8545

Which just need to add the option

--http.addr [::]

in the Geth comand.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.