1

My .sol files are reading like a text file...no different colors or autofill happening.

  • I'm using VS Code
  • I've used several different solidity extensions but the text is not being recognized as code.
  • I installed Solidity using my machines terminal.

I feel like I am missing something very basic here. Any ideas??

2
  • Which solidity plugin have you installed? Are they enabled?
    – Ismael
    Jan 13, 2023 at 5:22
  • - I have the suggested Solidity extension for Hardhat - Nomic Foundations - yes it is enabled
    – Derek Hall
    Jan 21, 2023 at 5:32

2 Answers 2

1

Press Ctrl+Shift+P then press enter or select "Format Document With..." Is solidity an option on this list? If so, select it.

0

This VSC extension helped me: "Solidity Language & Themes (only)" The code became colorful

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.