0

on an aws machine, lighthouse say it is synced. but Geth is not, for a few days now its syncing but keep the same distance between current and highest block(from eth_syncing response):

"currentBlock":"0xf93a7a"
"highestBlock":"0xf93ac2"

Geth recent print is that:

Jan 04 12:50:35 ip-172-31-23-187 geth[47297]: INFO [01-04|12:50:35.949] Forkchoice requested sync to new head    number=16,333,536 hash=b5851f..98ff42
Jan 04 12:50:36 ip-172-31-23-187 geth[47297]: INFO [01-04|12:50:36.599] Imported new block headers               count=1    elapsed="338.72µs"  number=16,333,536 hash=b5851f..98ff42
Jan 04 12:50:39 ip-172-31-23-187 geth[47297]: INFO [01-04|12:50:39.690] State heal in progress                   accounts=2,445,[email protected] slots=5,617,[email protected] [email protected] nodes=56,687,[email protected] pending=23018
9
  • It can because of the memory size you assigned to the running Geth. What is your system's RAM and how much RAM you assigned to this Geth?
    – Alireza
    Commented Jan 4, 2023 at 13:24
  • hey, thanks for the comment, i checked and ulimit -a says 'unlimited' memory size and 'free --mega' says i have 9595 mega free Commented Jan 4, 2023 at 15:40
  • You're welcome, The most important reason for Geth not syncing is memory consumption exceeding the system capacity. You should pay attention to this point that Geth is programmed with the Go lang and it is a property of this lang that it consumes twice the amount of memory allocated to it. So, check your system's RAM and see how much memory size Geth should consume for your system. Assign half this size to Geth.
    – Alireza
    Commented Jan 4, 2023 at 16:41
  • what do you mean assign memory to geth? it is unlimited and there is more memory available in the system. what am i missing? Commented Jan 4, 2023 at 16:53
  • Did you use --cache flag when you did run Geth? if yes, what number did you write after that? You should use --cache <a number in MB> to determine how much of memory should be assigned to Geth when it is running. If you didn't use this flag it sets the default value, that is 1024 MB. Try Geth by this flag instead unlimited and let I know the result.
    – Alireza
    Commented Jan 4, 2023 at 20:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.