i try much more time to connect rpc my geth, i got it cant run ,,syncmode light,, okay but can i used --syncmode fast? or how i connect in my rpc file , to be read from the geth side, also see the config.ini file, i am worked in ganache and working well my tools but cant run in geth my tools, please someone give me full comand which comand can i runing and what can i past in my config ini file, i mean local host and port

  • Have you updated Geth? ethereum.stackexchange.com/questions/134234/…
    – eth
    Commented Nov 27, 2022 at 11:06
  • Geth Version: 1.10.26-stable Git Commit: e5eb32acee19cc9fca6a03b102************* Architecture: amd64 Go Version: go1.18.5 Operating System: linux GOPATH= GOROOT=go
    – tomas
    Commented Nov 27, 2022 at 11:07
  • So your tools work with Ganache but now stopped working with Geth? Assuming Geth is all synced and working normally, the default localhost 8545 hasn't changed... You might need to mention what tool is no longer working? I am confused if your issue is with tools or running Geth.
    – eth
    Commented Nov 27, 2022 at 11:23
  • my tool worked perfectly with the ganache, now i want to test on goerli on sepolia and also on mainnet, my tool config.ini file include rpc = http:localhost:8545 this working nice in ganache, now i need to run a comand that will work the same way in geth, i can say i dont know what command to use to connect my tool rpc,
    – tomas
    Commented Nov 27, 2022 at 11:30
  • 1
    It is not clear to me if this question is about light client. Either way, you've provided more information and it might help someone else answer. I don't know and only other suggestion if you don't want to run usual Geth node with the links I've provided above, is to try the Geth Discord discord.com/invite/nthXNEv If you get an answer, please write answer here. (I will try to edit it if help is needed.)
    – eth
    Commented Nov 27, 2022 at 13:33

1 Answer 1


You can connect to the geth json-rpc via ipc using the following command:

geth attach /path/to/geth.ipc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.