0

I use Goerli testnet and I make the transaction compatible with EIP1559. I also use from etherscan gastracker api for getting desired low, average, and high values for maxFeePerGas. Issue is sometimes transaction does not send and goerli.infura give error "insufficient funs for gas * price + value", but when I increase maxFeePerGas value, transaction will send successfully.

**Notice that I use etherescan mainnet gasTracker for maxFeePerGas not goerli gasTracker. Does need to goerli gastracker? Is that possible, this issue doesn't occur on mainnet?

1
  • You should provide more details about a transaction that gives that error, like gas, value, maxFeePerGas and sender balance at the time. It could be a simple error as using a wrong unit for some of them, or using an incorrect value for them.
    – Ismael
    Nov 27, 2022 at 5:20

1 Answer 1

0

Like the error is saying: Within your account holding the Goerli Ether you should have a minimum of maxFeePerGas * gas + value. If you don't have this your transaction should be rejected by the libraries. Maybe try to switch to a more accurate provider like Alchemy or Infura. Lower latency helps getting better and faster results for queries.

1
  • Thanks. But I sure that I have minumum maxFeePerGas * gas + value on my account. I use infura too. Same transaction, first time getting error, but second time it is done without error.
    – mjdimn
    Nov 21, 2022 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.