1

On my solidity browser I get following error: Invalid JSON RPC response: ""

The way I use solidity browser: Download solidity-browser from the following link: unzipped the files and loaded index.html into the browser. /user/Downloads/browser-solidity-gh-pages/index.html.

Based on the following guide and guide-2, I run parity as follows: Please note that parity works perfectly fine, I can deploy a contract from parity's browser (localhost:8080).

parity --chain parity.json --network-id 23422 --reserved-peers myPrivateNetwork.txt --jsonrpc-apis web3,eth,net,parity,parity_accounts,traces,rpc,parity_set --rpc --rpcport  8545 --rpccorsdomain '*' --rpcaddr 127.0.0.1

Even I added following parameters as suggested on the guides: --rpc --rpcport 8545 --rpccorsdomain '*' --rpcaddr 127.0.0.1 it did not fix the Invalid JSON RPC response: "" problem.

When I run parity with this flag: --rpcaddr localhost instead of --rpcaddr 127.0.0.1 it also gives following error: Invalid JSONRPC listen host/port given: localhost:8545

Thank you for your valuable time and help.

  • use solidity browser without https. – Afr Apr 5 '17 at 11:54
  • I was using solidity browser on my local, Download solidity-browser from the following link: github.com/chriseth/browser-solidity unzipped the files and loaded index.html into the browser. /user/Downloads/browser-solidity-gh-pages/index.html. @ 5chdn – alper Apr 5 '17 at 11:57
  • how could I know, you linked the https version :) – Afr Apr 5 '17 at 12:00
  • Ups my bad, http version seems working but the contract never get deployed. Do you think is it possible to make it work with local solidity? @5chdn – alper Apr 5 '17 at 12:06
  • Sure, why not?- – Afr Apr 5 '17 at 12:12

Browse other questions tagged or ask your own question.